System not available

Incident Report for Numiga GmbH

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 11:42 CEST

Update

We are continuing to investigate this issue.
Posted Apr 14, 2026 - 11:38 CEST

Investigating

We would like to inform you that there is currently a technical issue.
Our team is already working intensively on a solution.
We will inform you immediately of any changes in status.

---

Wir möchten Sie darüber informieren, dass es aktuell einen technischen Fehler gibt.
Unser Team arbeitet bereits mit Hochdruck an einer Lösung.
Über Statusänderung werden wir Sie umgehend informieren.
Posted Apr 14, 2026 - 11:36 CEST
This incident affected: GoExpense.