Data Center Plutex partial Network problems
Incident Report for
Numiga GmbH
Resolved
This incident has been resolved.
Posted
Jan
29
,
2026
-
08:14
CET
Monitoring
We have currently identified partial network problems at our data center.
Posted
Jan
28
,
2026
-
17:45
CET
This incident affected: GoExpense, ProAudit, DIME - Dynamic Interface Manager Expense, Data Center, and Data Transport.
×
Subscribe to Incident
Subscribe to updates for
Data Center Plutex partial Network problems
via . You'll receive .